Tutorial : MSstats external tool Rat heart disease data — SRM with heavy labelling

MSstats as an External Tool

1. Annotating samples with group information

o Example data: rat plasma for heart failure

o 7 control samples and 7 disease samples

o 3 technical replicates

o Total 42 injections (runs)

o Label-free SRM

o Open the zipped Skyline file Rat_plasma.sky.zip in the folder
Tutorials/GroupedStudies/Heart Failure of Flash drive.

o Before we can run MSstats, we need to annotate which samples are replicates.
Skyline allows you to associate additional information with the runs in the document
by defining custom annotations. To view the Annotation Settings form, perform the
following steps:

o On the “Settings” menu, click “Document Settings...” > “Annotations” tab >
“Edit List...” > Select “Condition” and click “Edit...":

= Name: Condition
e Type: Value List
e Values: “Diseased”, “Healthy”, each on a new line (without ©
)
o Applies To: Replicates
e Click twice “OK” to confirm.

o After confirming the new annotation type, activate the 2 required Annotations
for MSstats by checking their checkboxes: Condition and BioReplicate (with
default settings).

o Click the “OK” button.

Document Settings “

Annotations | Group Comparisons | Reports

Annotations are extra pieces of data which you can attach to elements in a Skyline document. Use this dialog to control which
annotations are available in this document, as well as to define new annotations.

[] Run Add...
[] Subjectld
[] MissingData Edit List...

Condition

Gares

o Edit annotation values in Skyline using the Results Grid.

o To bring up the Results Grid, go to the “View” menu and click “Results Grid”.
The Results Grid will show you chromatogram peak areas and other
measured results for the currently selected peptide, or transition.

o Annotate “Condition”, “BioReplicate” as shown in the table below.
Caution! This table view will only be visible when a peptide is selected in the
target window. If a protein, a precursor or a transition is selected the columns
will change accordingly.
Caution! If you see little pencil icon at the left bottom, move the cursor to any
other cell to save all the information.
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Results Grid [ x | Results Grid B

Views ~ |4 4 |1 of2 | b bl || 53 Export. - Views ~ [4 4 |22 of2 | b bl || 53 Export.. B

Replicate BioReplicate Condition o] Replicate BioReplicate Condition A
> 102 Diseased v »4_ 146 Healthy v
D 102 REP2 102 Diseased v H 146 REP2 146 Healthy v
D 102 REP3 102 Diseased v H 146 REP3 148 Healthy v
D 103 REP1 103 Diseased v H 147 REP1 147 Healthy v
D 103 REP2 103 Diseased v H 147 REP2 147 Healthy v
D 103 REP3 103 Diseased v H 147 REP3 147 Healthy v
D 108 REP1 108 Diseased v H 148 REP1 148 Healthy v
D 108 REP2 108 Diseased v H 148 REP2 148 Healthy v
D 108 REP3 108 Diseased v H 148 REP3 148 Healthy v
D 138 REP1 138 Diseased v H 159 REP1 159 Healthy v
D 138 REP2 138 Diseased v H 159 REP2 159 Healthy v
D 138 REP3 138 Diseased v H 159 REP3 159 Healthy v
D 154 REP1 154 Diseased v H 160 REP1 160 Healthy v
D 154 REP2 154 Diseased v H 160 REP2 160 Healthy v
D 154 REP3 154 Diseased v H 160 REP3 160 Healthy v
D 172 REP1 172 Diseased v H 161 REP1 161 Healthy v
D 172 REP2 172 Diseased v H 161 REP2 161 Healthy v
D 172 REP3 172 Diseased v H 161 REP3 161 Healthy v
D 196 REP1 196 Diseased v H 162 REP1 162 Healthy v
D 196 REP2 196 Diseased v H 162 REP2 162 Healthy v

D 196 REP3 196 Diseased vilv H 162 REP3 162 Healthy vily

o Close the Results Grid.
o Save the Skyline file as Rat_plasma.sky in the folder.

2. Running MSstats

o MSstats is composed of three individual tools:
Quality Control (QC): Provides quality control statistics for MS runs and
performs run-level summarization of protein abundance to be used in
subsequent analysis. Logarithm transformation with base 2 and then

o

normalization to remove systematic bias between MS runs is applied.

Group Comparison: Tests for significant changes in protein abundance

across conditions based on linear mixed-effects models.

Design Sample Size: Calculates sample size for future experiments using an

intensity-based linear model.

Tip! For more detailed information about functionality and options, visit
msstats.org.

o Torun a QC analysis, perform the following steps:
For normalization with global standards, choose global standard proteins or
peptides.
Click peptide ‘VVLSGSDATLAYSAFK’

Right click and select ‘Set Standard Type’
Choose ‘Normalization’
Then ‘%’ is shown on the left side of the peptide name

(0]
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o On the “Tools” menu, choose “MSstats” and click “QC”.
Choose ‘Relative to global standards’ for normalization.
o Uncheck ‘Allow missing peaks’: whether adding incomplete rows in the input
or not.
= Option: To remove features with interference not agreeing with the
pattern of the average features across runs, check ‘Select high
quality features’.

(@)

Nomalization method:

l Relative to global standar v ‘

[] Allow missing peaks
[] Select high quality features

Allow the algorthm to d

Size of profile and QC plots
Width

10
Height
10

o By clicking “OK”, Skyline will begin to export the MSstats Input report. Once
the report is exported, Skyline will output the results of the tool run in the
Immediate Window docked at the bottom of the main Skyline Window.
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Immediate Window o X

** Loading the required statistical software packagesin R .....

Loading required package: Rcpp
Loading required package: grd
Loading required package: reshape?2

Reading the data for MSstats.....

Data Processing for analysis.....

bl

tal] 1Immediate Window
o When the tool is completed (“Finished.” In the Immediate Window), navigate
to the directory containing Rat plasma.sky under the folder
(Tutorials/GroupedStudies/Heart Failure). This directory should now contain
the outputs of the dataProcess function: dataProcessedData.csv,
ProfilePlot.pdf, QCPlot.pdf, ConditionPlot.pdf. There are also 2 text files
containing information about the software/package versions: msstats.log and
sessioninfo.txt.
o The three output plots help examine the data quality in the experiment.
= QCPIlot shows the boxplots of peak intensities (on log scale) in all
runs, where the bottom and top of a box represent the first and third
quartiles of the log-intensities and the band inside the box is the
median. It provides a quick way to examine and compare
distributions between runs, and to detect systematic bias.
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= ProfilePlot shows individual observations for each protein. It is useful
to examine the consistency of measurements in transition, run and
condition, and to detect potential source of variation and missingness
in the data.
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= Peptide VVLSGSDATLAYSAFK' was used for normalization, as
confirmed in the profile plot.

S
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= Parallel profiles on log scale correspond to consistent peak area
percentage (for example, peptide ‘NLGVVVAPHALR’), from which
we gain confidence in the integration of the peptide. When any
inconsistency is observed, we should look into the data before
conducting subsequent analysis.
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ProfilePlot_wSummarization overlays the summarized protein
abundance on top of the feature profiles.
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ConditionPlot shows the mean of log-intensity and 95% confidence
interval for each condition. To answer whether a protein is
differentially abundant between conditions, however, this plot is not
sufficient and group comparison analysis needs to be conducted.
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o Torun a Group Comparison analysis, perform the following steps:

(0]

O O O O

(0]

On the “Tools” menu, choose “MSstats” and click “Group Comparison”.

In the Name of comparison textbox enter “Disease-Healthy”.

Choose ‘Relative to global standards’ in Normalization method.

Click ‘Healthy’ in Control group.

Uncheck ‘Allow missing peaks’.

= Option: To select the most informative features which agree with the

pattern of the average features across the runs, check ‘Select high
quality features’.

Click the ‘OK’ button of the MSstats Group Comparison form.

Name of comparison:
Disease-Healthy
Nomalization method:
Relative to global standards

[] Allow missing peaks

[] Select high quality features

vControl group:
» Healthy

The Group Comparison tool will now perform its analysis. When the group
comparison run is completed, switch back to the directory containing the
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Rat_plasma.sky file. The directory should now contain VolcanoPlot,
ComparisonPlot PDF files, TestingResult.csv file, and msstats-1.log file and
dataProcessedData-1.csv generated by the tool.

o Results of the group comparison including log2 fold change, standard error,
and adjusted p-value are shown in TestingResult.csv.

] B C D E F G H 1 J K L ™M
1 Protein Label log2FC SE Tvalue DF pvalue adj.pvalue issue MissingPerce ImputationPercentage
2 1 NP_0010076 Diseased-He: -1.0226015 0.27588304 -3.7066487 28 0.0009173 0.00314504 NA 0.0218254 0.0218254
3 2 NP_0010087 Diseased-Hei 0.39338814 0.28846953 1.36370778 28 0.18352357 0.23181925 NA 0 0
4 3 NP_0010109 Diseased-He: 0.31582353 0.19613331 1.61024933 28 0.11856115 0.16071834 NA 0.04285714 0
5 4 NP_0010119 Diseased-He: -0.4626898 0.20845312 -2.2196346 28 0.03471625 0.05237893 NA 0.00621118 0
6 5 NP_0010120 Diseased-He: 0.56940559 0.30114834 1.85078111 28 0.06504307 0.10042629 NA 0.0014881 0.0014881

o Volcano plot summarizes all the proteins with respect to their practical
significance (log2 [fold change]) and statistical significance (-log10 [adjusted
p-value]). Proteins with greater y values are more statistically significant.
Changes with an adjusted p-value less than a significance level (default of
0.05) are considered as statistically significant. Up-regulated and down-
regulated proteins are shown in red and blue, respectively.

Diseased—Healthy

100 NP_036714

NP_0§8716
NP_1 30641

N P_a 6487

50

NP_030020 NP_d36s828
NP_062242
xp_oomgsooa’

-Log10 (adjusted p-value)

ﬁp_mw

NP_075213 0368745
3 NP
NP_082212 NP_ .';gz,NP_oaeam
23 NP_001007607 NP_0368016 NP_058690
NP_036789 S-NE—&QIN’ P 445770

o % NR_75sBzayoNp_ 13692

0.0

o
Log?2 fold change

Adj p-value cutoff (0.05)

No regulation ® Down—r lated ® Up-regulated

o To run a sample size calculation analysis, perform the following steps:
o On the Tools menu, choose MSstats and click Design Sample Size.
o Choose ‘Relative to global standards’ in Normalization method.
o Uncheck ‘Allow missing peaks’
= Option: To select the most informative features which agree with the
pattern of the average features across the runs, check ‘Select high
quality features’.
o For this tutorial you will leave the options in their default settings.
= The default setting will calculate sample size in order to get
power=0.8 with FDR=0.05 between 1.25 and 1.75 fold change.
= One of “Sample size” or “Power” needs to be selected for calculation.
The other value needs to be provided.
o Click the OK button of the MSstats Design Sample Size form.
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Nomalization method:

‘ Relative to global standar v

[] Allow missing peaks
[] Select high quality features

Automatically calculate
(® Sample size

() Power
om

FDR:
0.05

o The Design Sample Size tool will now perform its analysis. When the analysis
is completed, switch to the directory Rat_plasma.sky file again. The directory
should now contain a SampleSizePlot PDF file, SampleSizeCalculation CSV
file, and msstats-2.log and dataProcessedData-2.csv file generated by the
tool.

o Required sample size corresponding to each of the expected fold changes
(effect size) is reported in SampleSizeCalculation.csv. For example, to detect
a fold change of 1.3 with power 0.8 and false discovery rate 0.05, the
minimum required sample size (per condition) is 11.

desiredFC  numSample FDR power cv

1.25 15 0.05 0.8 0.004
1.275 13 0.05 0.8 0.005
13 11 0.05 0.8 0.006
1.325 S 0.05 0.8 0.007
135 8 0.05 0.8 0.008
1375 7 0.05 0.8 0.008
14 7 0.05 0.8 0.008
1.425 6 0.05 0.8 0.01
145 5 0.05 0.8 0.011
1.475 5 0.05 0.8 0.011
15 5 0.05 0.8 0.011
1.525 4 0.05 0.8 0.013
1.55 4 0.05 0.8 0.013
1.575 4 0.05 0.8 0.013
16 3 0.05 0.8 0.017
1.625 3 0.05 0.8 0.017
1.65 3 0.05 0.8 0.016
1.675 3 0.05 0.8 0.016
17 3 0.05 0.8 0.016
1.725 3 0.05 0.8 0.016
175 2 0.05 0.8 0.023
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o SampleSizePlot visualizes the results in SampleSizeCalculation.csv

Coefficient of variation, CV
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T T
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o To help troubleshoot potential problems with installation or functionalities of MSstats,
a progress report is generated in a log file msstats.log. The file includes information
on the R session (R version, loaded software libraries), options selected by the user,
checks of successful completion of intermediate analysis steps, and warning

messages. If the analysis

produces an error, the file contains suggestions for

possible reasons for the errors. If a file with this name already exists in working
directory, a suffix with a number will be appended to the file name.

File Edit Format View Help

"Running under: Windows 8.1
"locale:"

"[4] LC_NUMERIC=C
"[5] LC_TIME=English_United
"attached base packages:"

"[8] base "
"other attached packages:"

" [1] gtools_3.5.0
" [4] lattice_0.20-33
" [7] chron_2.3-47

"R.version.3.2.4..2016.03.10." A
"Platform: x86_64-w64-mingw32/x64 (64-bit)"

“[1] LC_COLLATE=English_United States.1252 "
“[2] LC_CTYPE=English United States.1252 "
“[3] LC_MONETARY=English_United States.1252"

"[1] grid stats graphics grDevices utils datasets methods

"[1] MSstats_3.3.11 reshape2_1.4.1 Rcpp_0.12.4 ggplot2_2.1.0 "
"loaded via a namespace (and not attached):"

msstats-2 - Notepad - o lEl

x64 (build 9600)"

States.1252 "

minpack.1lm_1.2-0 splines_3.2.4 "
colorspace_1.2-6 stats4_3.2.4 "
vsn_3.38.0 survival_2.38-3

10



